Froschs Blog

Computer und was das Leben sonst noch so zu bieten hat

Zur Website | Impressum

Spaß mit CF-Karten

19. April 2009 um 21:14 Uhr von Atari-Frosch

Ein netter Zeitgenosse hat mir leihweise eine Digitalkamera zur Verfügung gestellt. Soweit, so gut. Ich habe ein paar Testbilder gemacht und wollte die jetzt auf meinen PC übertragen. Das ist aber offenbar mit so einigen Hürden verbunden:

In der Kamera war eine CF-Karte der Marke takeMS mit 512 MB Kapazität. Darauf habe ich auch die ersten Aufnahmen gemacht und konnte sie auch auf dem Kameradisplay wieder abrufen. Dann habe ich die Karte entnommen und in meinen Kartenleser gesteckt. dmesg meldete mir zwar den Kartenleser (als /dev/sdc), aber nicht die Karte. Auch cfdisk behauptete, da sei kein Gerät. Hm.

Den zweiten Versuch unternahm ich mit einer Transcend-Karte mit 2 GB Kapazität. Diese hatte ich letzten Sommer für meine HP PhotoSmart C30 gekauft, und die hatte darin auch funktioniert. Eine Weile jedenfalls. Danach ließ sich die Karte scheinbar am PC nicht mehr einlesen. Ich formatierte diese Karte jetzt in der Leih-Kamera, machte zwei Bilder, entnahm die Karte wieder und steckte sie in den Leser. Das Ergebnis war exakt das gleiche wie mit der takeMS-Karte.

Dritter, fast schon verzweifelter Versuch: Ich testete die alte 8-MB-Karte von SanDisk, die ursprünglich bei der PhotoSmart dabei gewesen war, erst am PC: Sie wurde erkannt und konnte gemountet werden. Also schob ich diese Karte in die Leih-Kamera, die sich gleich mal beklagte (vermutlich wegen der geringen Kapazität). Trotzdem konnte ich die Karte formatieren und genau ein Bild drauf machen. Im Kartenleser wurde die Karte wieder erkannt, und ich konnte das Bild auch auf den PC kopieren.

Das Ergebnis des dritten Versuchs schließt schon einmal aus, daß der Kartenleser defekt sein könnte.

Ich probierte es noch einmal mit der 2-GB-Karte: In den Leser einstecken, kurz warten, nachsehen, ob das Device angelegt wurde -- hoppla, da war's ja auf einmal doch! Also gleich gemountet, das ging auch, und dann versucht, die Bilder auf den PC zu kopieren. Fehlanzeige: I/O error. Und zwar eindeutig von der Karte her, nicht von der Platte (obwohl ich die Tage meine primäre Platte durchaus im Verdacht hatte und immer noch habe, nicht mehr ganz in Ordnung zu sein). Von den 2,9 MB, die das erste Bild hatte, landeten ganze 80 kB auf der Platte, dann gab der mc auf.

Die reine Größe der CF-Karten kann  nicht das Problem sein; mit der 2-GB-Karte hatte ich ja schon Bilder von der PhotoSmart auf den PC übertragen. Ich kann mir auch nicht vorstellen, daß beide großen Karten kaputt sein sollen. Testen kann ich das aber wohl nur, indem ich mir nochmal eine CF-Karte kaufe. 🙁

Update 20.04.2009: Es war doch der Kartenleser. Heute Morgen fiel mir auf, daß dann, wenn ich eine Karte einsteckte, meistens die Power-Lampe ausging. Das Ding hatte also einfach einen Wackelkontakt. Neuen Card-Reader gekauft, jetzt kann ich die Bilder problemlos übertragen — von allen Karten.

Kommentieren

Bitte beachte die Kommentarregeln!

XHTML: Du kannst diese Tags verwenden: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>