Froschs Blog

Computer und was das Leben sonst noch so zu bieten hat

Zur Website | Impressum

(Gar nicht so) lustige Effekte mit znc 0.098

25. Mai 2011 um 15:20 Uhr von Atari-Frosch

Beim letzten Serverumzug im Oktober letzten Jahres hatte ich wohl was vergessen. Und zwar fehlte mir jetzt das Webinterface zum IRC-Bouncer ZNC, den ich für mehrere IRC-Netzwerke nutze. Naja, dachte ich, ist nicht wirklich schlimm, außerdem eine gute Gelegenheit, die aktuelle Version einzuspielen, denn ich hatte noch die alte vom alten (virtuellen) Server laufen.

Also mal eben den Quellcode runtergeladen, ausgepackt, ein paar zusätzliche Pakete zum Compilieren installiert, .configure, make und make install, die Config-Dateien gesichert, den alten ZNC-Prozeß abgeschossen und den neuen (wie bisher auch unter einem separaten User) gestartet. Ich sollte endlich mal lernen, daß „mal eben” in den wenigsten Fällen funktioniert ...

Erstmal konnte ich mich ganz normal mit dem Webinterface verbinden. Ich loggte mich also mit meinem Hauptaccount ein, legte den neuen User an, den ich haben wollte, klickte auf „create” und landete wieder auf der Hauptseite. In der Userliste taucht der neue User jedoch nicht auf. Neuer Versuch, nochmal alles eingegeben, „create” — nichts zu machen. Der User wird nicht angelegt. Übrigens werden auch Änderungen an bestehenden Accounts nicht angenommen. Für Fehlermeldungen ist sich der ZNC aber wohl zu fein, sowohl direkt im Webinterface als auch in irgendeinem Log. Ich bin unter Linux wirklich gesprächigere Programme gewöhnt.

Woran denkt man in so einem Fall als erstes? Natürlich, Rechteproblem. Allerdings gehören alle Konfigurationsdateien genau dem User, mit dem ich den ZNC auch gestartet habe. Rechte: 700 für Ordner und Dateien, wie zuvor auch. Außerdem konnte ich mich mit XChat ganz normal mit den bisherigen Daten auf den ZNC verbinden, und das mit derzeit drei Accounts.

Auch eine Erweiterung der Dateirechte auf 750 hat nichts gebracht.

Weil Opera ja gelegentlich seltsame Dinge tut (er kann zum Beispiel einige Websites nicht korrekt oder überhaupt lesbar darstellen), ging ich auf Nummer Sicher und startete den iceweasel, um es mal damit zu versuchen. Da passiert aber gleich was ganz lustiges: Sobald ich die Adresse des Webinterfaces eingegeben habe und Return drücke, schmiert iceweasel kommentarlos und reproduzierbar ab. Hm.

Übrigens funktioniert auch der Logout nicht.

Eigentlich hatte ich den ZNC in den letzten Jahren immer selbst compiliert, weil die Debian-Versionen nicht nur fürchterlich veraltet, sondern auch SSL-frei waren. Nach Rücksprache mit einem anderen ZNC-Benutzer (bei dem ich ebenfalls einen ZNC-Account habe) stellte ich nun gerade überrascht fest, daß die ZNC-Version in Debian Squeeze SSL spricht. Außerdem verfügt das — funktionierende — Webinterface über alle Module, die ich auch in dem des 0.098 gesehen habe. Und das sind eine ganze Menge! Ich muß wohl eine sehr alte Version (auch selbst compiliert) laufen gehabt haben, oder da hat sich in letzter Zeit verdammt viel getan.

Von der 0.098 muß man dann wohl erstmal abraten, zumindest, wenn sie über eine existierende Installation drübergebügelt wird. Da ist möglicherweise was karpott.

Kommentieren

Bitte beachte die Kommentarregeln!

XHTML: Du kannst diese Tags verwenden: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>