Froschs Blog

Computer und was das Leben sonst noch so zu bieten hat

Zur Website | Impressum

Mikrofon-Animositäten

11. August 2011 um 1:02 Uhr von Atari-Frosch

Bis vorgestern Abend war Telefonieren mit Skype überhaupt kein Problem. Aber dann hieß es plötzlich von einem Gesprächspartner: Ich hör Dich nicht. Da es bei mir vorher keine Probleme gab, dachte ich, es liegt an seinem Rechner. Aber dann kam der nächste, der mir sagte, er höre mich, aber nur ganz ganz leise. Da ging ich dann doch mal auf die Suche.

Ich begann damit beim alsamixer. Dort sah auf den ersten Blick alles normal aus. Mic aus, aber Front Mic an und hochgedreht und der Boost noch ein Stück mit dazu. Lokal konnte ich mich auch im Kopfhörer hören. Aber offenbar ging das Signal nicht raus.

Der besseren Übersicht halber wechselte ich in der Ansicht des alsamixers auf die reinen Aufnahmeregler. Und siehe da: Als Input Device war da nicht Front MIC, sondern MIC angegeben. Ich habe das Mikrofon aber am Frontpanel angeschlossen, nicht hinten direkt an der (Onboard-)Soundkarte. Na, dann kann das ja nicht gehen. Also habe ich das Input Device umgestellt.

Noch verwirrender wurde die Sache, nachdem ich dann beim „Skype Test Call” angerufen hatte. Dort kann man ca. 15 Sekunden lang etwas reinquaken, und dann wird das, was Skype empfangen hat, wiedergegeben. Das funktionierte, ich hörte mich in der Wiedergabe. Der nächste Gesprächspartner sagte aber wieder: Nein, ich höre Dich nur ganz leise. WTF???

Also wieder in den alsamixer, wieder in die Aufnahme-Darstellung. Da war noch was: Capture nennt sich der Balken, und der stand bei 3 %. Also habe ich den noch hochgeschraubt. Und siehe da: Es ging.

Bis ich mal zwischendurch das Mikrofon ausschaltete (direkt am Gerät).

Zwar war die Einstellung des Input Device erhalten geblieben, aber Capture stand wieder bei 3 %. Ja wie ...?

Ich tat meinen Unmut erstmal auf Twitter kund.

Ich finde es übrigens überhaupt nicht gut, daß sich der alsamixer offenbar von selbst verstellt hat ...

Und prompt bekam ich Antwort von @Emil_Blume:

Daram könnte die Erkennungsfunktionalität der Hardware bei einem unbeabsichtigtem Umstecken schuld sein. #alsa #verstellung

Schau an. Das heißt, der Mixer kann sich einfach so verstellen, wenn das Mikrofon umgestellt wird. Mehr noch: Hier sogar dann, wenn es einfach nur aus- und wieder eingeschaltet wird! — und dann fiel mir ein, daß ich vor dem Auftreten des Problems tatsächlich mal kurz das Mikrofon ab- und wieder angestöpselt hatte. Das war's dann wohl.

Das erinnerte mich an noch etwas: Da war doch vor drei Jahren diese Sache mit dem Geist in der Maschine gewesen, wo sich auch der alsamixer verstellt hatte, nachdem ich das Mikrofon mal kurz abgezogen hatte. Und das war ein völlig anderer Rechner (allerdings dasselbe Mikrofon).

Kann man das irgendwie abstellen, daß der alsamixer da so einfach die Einstellungen ändert, nur weil ich mal zwischendurch das Mikro ausschalten möchte? Denn ein bißchen stört das schon. Klar, ich könnte das Mikro im alsamixer abschalten, aber den will ich deshalb nicht jedes Mal starten müssen; abschalten direkt am Gerät ist einfacher.

Ein Kommentar zu “Mikrofon-Animositäten”

  1. Frank quakte:

    Hallo Frosch,
    beim ALSA-Mixer, hast ja eigentlich die Option, daß die Capture-Einstellungen, auf Micro,Line,Mixer,Video usw. setzen kannst. Versuche doch mal, Capture nicht auf Micro zu setzen, sondern auf Mixer.
    Halt mal, als Versuch.
    Gruß FRANK


Kommentieren

Bitte beachte die Kommentarregeln!

XHTML: Du kannst diese Tags verwenden: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>