Froschs Blog

Computer und was das Leben sonst noch so zu bieten hat

Zur Website | Impressum

Multimediale Verpeilung

13. August 2011 um 23:56 Uhr von Atari-Frosch

Heute ist mal wieder so ein Tag. So einer, an dem ich mir was vornehme, und dann erstmal alles schiefläuft und mir Geräte und Software alles an auffindbaren Steinen in den Weg werfen. Leider hab ich sowas öfter ...

Der Plan war gewesen, das Wochenende dazu zu nutzen, mal wieder einige Schallplatten zu digitalisieren. Das letzte Mal war schon einige Zeit her, ich hatte auch mal das Kabel zwischen Verstärker und Soundkarte für einen anderen Zweck abgezogen gehabt. Und ich dachte, naiv wie ich bin, es genüge, dieses Kabel eben einfach wieder einzustecken, denn die Konfiguration von audacity wie auch die Einstellungen am Verstärker hatte ich seitdem nicht angefaßt. Soviel zur Theorie.

Dieser Verstärker ist Teil einer älteren Philips-Anlage, so richtig mit Radioteil, Cassettendeck, obendrauf Plattenspieler, und das Ganze auch noch richtig schick in einem Phonoschrank verbaut. Er hat hinten nicht einfach nur zwei oder drei Geräteanschlüsse (jeweils 2 x Chinch), sondern eine ganze Reihe dieser Buchsen-Paare. Ich steckte die beiden Stecker des Kabels also einfach irgendwo rein, verband auf der anderen Seite mit Line-In der Soundkarte, legte eine Platte auf, und es kam — nichts. Der Kopfhörer war richtig angeschlossen; davon überzeugte ich mich durch Abspielen eines MP3 in audacious.

Es dauerte ganze drei Stunden (OK, Essen gemacht habe ich zwischendurch auch noch, aber nicht sonderlich aufwendig), bis ich herausfand, daß es nicht egal ist, wo ich die beiden Stecker am Verstärker reinstopfte. Es mußte unbedingt das sechste Buchsen-Paar von außen her sein. Nun denn. Aber es wäre zu einfach gewesen, wenn das das einzige Problem gewesen wäre.

Nun kam das Signal also durch, ich stellte audacity auf Recording und startete den Plattenspieler. audacity zeichnete ganze drei Sekunden auf und blieb dann stehen. Nein, er hängte sich nicht auf, auch der Record-Button sprang nicht wieder in die Ausgangsstellung, aber die Aufzeichnung ging nicht weiter. Abspielen konnte ich diese drei Sekunden. Mehr war nicht da.

Ich überprüfte den Plattenplatz. Kein Problem, mehrere Gigabytes auf der Zielpartition frei.

Beim nächsten Versuch wurde gar nichts aufgezeichnet. Ich drückte also wieder auf Stop, und audacity verabschiedete sich. In /var/log/messages fand sich die nicht sehr hilfreiche Information:

Aug 13 17:25:11 seefunk kernel: [ 7625.654118] audacity[2481]: segfault at 8 ip 0824ef44 sp b5399110 error 4 in audacity[8048000+64f000]

Ich probierte allerhand Einstellungen im alsamixer aus, ohne Erfolg.

Zwischendurch schrieb ich eine Anfrage nach Google+ und ins Debian-Forum, ob da jemand eine Idee hätte.

Dann klemmte ich das Mikrofon an, um auszuschließen, daß es am Line-In liegt. Es lag nicht am Line-In: gleiches Ergebnis. Eine Sekunde Aufzeichnung, dann nichts mehr.

Als ich im IRCNet davon erzählt hatte, kam von Nurbs — zunächst unwissentlich — der richtige Hinweis. Welchen Kernel ich denn drauf hätte. Ich war davon ausgegangen, daß es natürlich der Distributions-Kernel von Squeeze ist. uname -a klärte mich jedoch darüber auf, daß das noch ein 2.6.26er ist. Nanü?

Offenbar hatte ich das Upgrade von Lenny nach Squeeze nicht vollständig durchgezogen, warum auch immer. Vielleicht war ich zu müde oder zu unkonzentriert. Also installierte ich das Kernel-Image 2.6.32 nach, was noch ein paar Systemveränderungen mit sich zog, und rebootete. Und siehe da: audacity wollte wieder aufzeichnen.

Naja, fast. Der Fortschrittsbalken lief zwar, aber es wurde nichts aufgezeichnet. Nicht vom Mikro, nicht von Line-In. Also spielte ich nochmal ein bißchen im alsamixer herum und drehte schließlich AC97 auf. Das ist normalerweise runtergedreht, weil das beim Radiostreamen stört — man hört dann nur noch häßliche Pfeifgeräusche statt der Musik. Ich muß also zum Streamen den Mixer anders einstellen als zum Digitalisieren.

Und beim Einlesen der zweiten Seite der ersten LP blieb audacity dann doch nochmal stehen, knapp vorm Ende des zweiten Tracks. Keine Ahnung, warum. Beim zweiten Versuch lief es anstandslos durch.

Vom Beginn meiner Bemühungen bis zur fertig eingelesenen und encodeten ersten LP vergingen jedenfalls fast sechs Stunden ...

Kommentieren

Bitte beachte die Kommentarregeln!

XHTML: Du kannst diese Tags verwenden: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>