Froschs Blog

Computer und was das Leben sonst noch so zu bieten hat

Zur Website | Impressum

Spaß mit Soundblaster

Mittwoch, 1. August 2012

Heute hab ich mal wieder eine Story aus der Serie „Spaß mit (alter) Hardware“. Ist ja nicht so, daß ich sonst keine Probleme hätte, aber es muß halt immer noch irgendwo eine Kleinigkeit mit obendrauf kommen.

In meinen beiden Desktop-PCs hier, seerose und seefunk, habe ich mittlerweile jeweils eine Soundblaster Emu10K1. Die Modelle sind nicht exakt gleich, aber sie benutzen den gleichen Treiber und liefern die gleiche gute (im Verhältnis zu ihrem Preis und im Vergleich zu anderen Karten in dem Segment) Qualität. Beide PCs laufen mit Debian GNU/Linux Squeeze, seerose in 64bit, seefunk in 32bit. Bei seerose geht alles. seefunk dagegen meint seit kurzem, mit seiner Soundblaster nicht mehr reden zu müssen. Das sieht dann in dmesg so aus: (mehr …)


Einer dieser Tage …

Donnerstag, 10. Mai 2012

... die man am liebsten aus dem Kalender streichen würde. Heute: Eine verschlampte Paket-Benachrichtigung, viele verlorene Erinnerungen und ein kaputter PC.

Das mit der Paketbenachrichtigung fing eigentlich schon gestern an. Meine Mutter hatte mir ein Paket mit Fotoalben angekündigt. Über Hermes, wie ich ihr gesagt hatte – noch zu der Zeit, als der DHL-Bote die Pakete grundsätzlich nicht ablieferte. Ich rief sie also gestern an und fragte nach der Auftragsnummer, weil ich noch nichts bekommen hatte. Mit der Nummer suchte ich online bei Hermes nach: Das Paket war am 28. April in einem Shop abgegeben worden. In welchem, stand nicht dabei. Also schickte ich eine Rückfrage übers Kontaktformular. (mehr …)


VCFE 2012

Montag, 30. April 2012

Das war ein eindrucksvolles Wochenende, im wahrsten Sinne des Wortes. Aber bevor ich über meine Eindrücke vom Vintage Computing Festival Europe berichte, muß ich erstmal ein paar Leuten danken:

  • dem Organisator Hans Franke, auch wenn er manchmal ein bißchen zu pedantisch war 😉
  • meinen Sponsoren Venty und XTaran für die Finanzierung der Fahrt und des „Aussteller-Packs“ – ohne Euch wäre ich da nie hingekommen.
  • Beetle für einen zweiten Atari Portfolio mitsamt Steckmodulen für parallele und serielle Schnittstelle und Kabeln – ohne das zweite parallele Steckmodul hätte ich meinen Portfolio wohl nicht von außen ansprechen können. Außerdem hat er mir fünf Euro geliehen, um am Flohmarkt-Stand ein weiteres paralleles ZIP-Laufwerk zu kaufen, weil meins zwar intakt, aber für den Portfolio-Treiber zu neu und ich pleite war. Und überhaupt für die Hilfsbereitschaft die ganze Zeit über, das muß ich einfach nochmal extra erwähnen, weil das nicht so selbstverständlich ist.
  • Ragnar vom Chaosdorf fürs Rauftragen des schweren Trollys in den fünften Stock mitten in der Nacht nach der Rückfahrt. Das macht ja schließlich auch nicht jeder.

(mehr …)


Systemabsturz

Donnerstag, 9. Februar 2012

Ich bin ja als Linux-User generell PC-Abstürze nicht so gewohnt 😉 – aber das hatte ich so auch noch nicht: Display hatte plötzlich kein Signal mehr, und die Tastatur reagierte auch nicht mehr (NumLock-Test). Der PC lief zwar weiter, aber ich war ihm gegenüber quasi blind und stumm. Aus dem Dilemma kam ich nur mit einem harten Reboot raus, also Ausschalten am Netzteil und dann wieder neu starten. Jetzt läuft er wieder, aber ich werd das wohl mal im Auge behalten müssen.

Nicht daß mir da jetzt auch noch was stirbt … wäre ja genau passend. Der Multimedia-PC braucht gerade eine neue Systemplatte, weil die bisherige sich in die Rente verabschiedet hat, und auf dem Notebook findet grub nach dem letzten größeren Upgrade seinen Kernel nicht mehr (Luks-LVM, nur /boot unverschlüsselt).

Die Logeinträge sind nicht sonderlich aussagekräftig. /var/log/kern.log sagt nur: (mehr …)


„Mein Computer ist kaputt!”

Freitag, 19. August 2011

„Mein Computer ist kaputt!” — wenn mich ein solcher Anruf aus dem Bett holt, ist meine Tagesplanung im allgemeinen genauso kaputt. So auch heute.

Ergebnis der Untersuchung: Platte gestorben. Nun hofft die Besitzerin darauf, daß ich die Daten vielleicht noch retten könnte. Die Partitionen werden unter Linux noch gesehen, das NTFS ist aber wohl ein wenig kaputt, denn mounten geht nicht. Natürlich hat die Dame kein Backup, wäre ja zu einfach. Mal sehen, ob ich da mit Linux-Bordmitteln noch was runterkratzen kann (Tips willkommen!). Ich habe ihr aber schon gesagt, daß sie sich nicht allzu große Hoffnungen machen soll. Die Größe der Platte ist mit 250 GB dabei ein gewisses Handicap. Kopieren kann ich die größte der Partitionen mit Windows und den Daten nämlich nicht. So viel Platz hab ich hier nicht. (mehr …)


apt-get install segfault

Mittwoch, 17. August 2011

Ab Montag Abend meinten apt-get und apt-cache, auf meinem Hauptrechner seerose Speicherzugriffsfehler (segmentation fault) werfen zu müssen, und auch exakt nur diese beiden Programme. Alles andere, auch die größten Speicherfresser, wußten nichts von Speicherproblemen. Auf dem Server, der ja auch ein 64bit-System ist, probierte ich das gleiche, aber da gab es keine Probleme.

Vor dem Schlafengehen steckte ich also die Ultimate Boot CD ins Laufwerk, rebootete und startete den memtest86+ (+, weil der mit 64bit kann). Dienstag, 9 Stunden und 20 Minuten später, war der Test beim Einschalten des Monitors gerade im 6. Durchlauf bei 15 % und hatte keine Speicherfehler gefunden. Damit wurde es kompliziert. (mehr …)


Multimediale Verpeilung

Samstag, 13. August 2011

Heute ist mal wieder so ein Tag. So einer, an dem ich mir was vornehme, und dann erstmal alles schiefläuft und mir Geräte und Software alles an auffindbaren Steinen in den Weg werfen. Leider hab ich sowas öfter ...

Der Plan war gewesen, das Wochenende dazu zu nutzen, mal wieder einige Schallplatten zu digitalisieren. Das letzte Mal war schon einige Zeit her, ich hatte auch mal das Kabel zwischen Verstärker und Soundkarte für einen anderen Zweck abgezogen gehabt. Und ich dachte, naiv wie ich bin, es genüge, dieses Kabel eben einfach wieder einzustecken, denn die Konfiguration von audacity wie auch die Einstellungen am Verstärker hatte ich seitdem nicht angefaßt. Soviel zur Theorie. (mehr …)


Mikrofon-Animositäten

Donnerstag, 11. August 2011

Bis vorgestern Abend war Telefonieren mit Skype überhaupt kein Problem. Aber dann hieß es plötzlich von einem Gesprächspartner: Ich hör Dich nicht. Da es bei mir vorher keine Probleme gab, dachte ich, es liegt an seinem Rechner. Aber dann kam der nächste, der mir sagte, er höre mich, aber nur ganz ganz leise. Da ging ich dann doch mal auf die Suche.

Ich begann damit beim alsamixer. Dort sah auf den ersten Blick alles normal aus. Mic aus, aber Front Mic an und hochgedreht und der Boost noch ein Stück mit dazu. Lokal konnte ich mich auch im Kopfhörer hören. Aber offenbar ging das Signal nicht raus. (mehr …)


Erinnerung ans Backup

Sonntag, 1. Mai 2011

Mein derzeitiger Hauptrechner ist ja nur ein Provisorium. Das ist eigentlich mein Zweit-PC, den ich auf die Aufgaben Webradio-Stream und Video-Digitalisierung getrimmt hatte. Nach den Problemen mit dem DualCore hatte ich dem erstmal eine andere Platte verpaßt und darauf den neuen Hauptrechner aufgebaut. Das Sprichwort „nichts hält länger als ein Provisorium” hatte ich mal wieder verdrängt — und daher keine Backups gemacht. Das Provisorium besteht jetzt schon seit über fünf Monaten.

Heute morgen dann der Schreck: Einschalten, booten beginnt, aber noch vor der Abfrage der Crypto-Passphrase für die Systemplatte kam eine Kernel Panic. Reboot. Das BIOS erzählt mir, es habe nichts gefunden, wovon es booten könnte. 😯 (mehr …)


Fehlersuche im Netzwerk (3)

Dienstag, 22. März 2011

(Schlußbericht zur Fehlersuche im Netzwerk und Fehlersuche im Netzwerk, Teil 2)

Nun ist es ganz klar: Der Router war der Bösewicht. Heute kamen die neuen Zugangsdaten. Ich schloß das bisherige DSL-Modem wieder an, klemmte den geliehenen LinkSys-Router mit dazu und fütterte letzterem die Zugangsdaten ein. Die Verbindung war sofort da, keinerlei Paketverluste. (mehr …)


Mainboards und Standards

Mittwoch, 5. Januar 2011

Ich hätte ja gern ein bißchen an meinem neuen Hauptrechner weitergemacht. Da habe ich aber zwei kleine, aber sehr störende Probleme:

Der Anschluß für den Gehäuselüfter liegt auf dem Board in optimaler Entfernung zu ebendiesem. Der Lüfter sitzt auf der Rückseite, bei aufrecht stehendem Midi-Tower neben den ausgehenden Schnittstellen. Der Anschluß sitzt auf dem Board fast ganz unten. Das Kabel müßte um die Grafikkarte herum nach unten geführt werden — und ist dafür zu kurz.

Bei den Onboard-USBs sind die Anschlüsse auch alle ganz unten, aber das Kabel, das von den in der Frontblende befindlichen Kartenlesern ins Gehäuse hinein geführt ist, reicht von der Länge her locker hin. Hier ist das Problem ein anderes. (mehr …)


Hardware-Fuckup

Donnerstag, 2. Dezember 2010

Heute kam's mal wieder dicke. Ich hatte vormittags einen Behördentermin gehabt (ausnahmsweise mal nichts mit bösen Nachwirkungen), vorher natürlich schon in die Mail und Twitter usw. geschaut und den PC laufen gelassen. Als ich etwa eine Stunde später zurückkam, sah die Oberfläche ein wenig ... kaputt aus. Die Menüleiste unten war durchgehend schwarz bis auf das Icon von XChat, und irgendwie fehlten auch die Ränder der Anwendungsfenster. Ein paar Tasten durfte ich noch drücken, dann blinkte die Tastatur im Takt, und der Rechner sagte gar nix mehr.

Nach dem Reboot kam von der Festplatte ein leises, aber regelmäßiges Ticken — ZU regelmäßig, um normal zu sein. Oder sagen wir besser: Nach dem versuchten Reboot. fsck meinte nämlich, eine Datenpartition auf der Systemplatte sei ein wenig sehr kaputt. Ich wurde in den Maintenance-Modus geschickt. (mehr …)


Computer-Déjà-vu

Donnerstag, 18. November 2010

Vor drei Jahren, nur einen knappen Monat später, ging mein damaliger Hauptrechner seerose (P III/500) in Rente. In einer der übelsten Zeiten für mich im Jahr, was die Depressionen angeht, und relativ kurz vor meinen jährlichen Fahrten nach Mannheim (Mutter) und Berlin (Congress). Auch wenn seerose (Athlon 1800XP+) nicht so radikal abtrat — genaugenommen ist er sogar noch nutzbar, wenn auch mit Einschränkungen — fühlte ich mich daran erinnert, unter welchen Umständen ich den damals zusammengeschraubt hatte.

Mir waren jedenfalls die ständigen Abstürze zu viel geworden, ich fühlte mich ja schon wie ein Windows-User. Zunächst hatte ich ja Opera im Verdacht gehabt. Mir hatten auch andere gemeldet, daß Opera „gern mal abstürzt”, allerdings konnte keiner bestätigen, daß dabei X oder das ganze System mitgerissen wird. Ich hatte also am Freitag Abend, bevor ich ins Bett ging, einen memtest86 gestartet. Am nächsten Morgen kam ich rein, und der PC war einfach aus. Aber so richtig aus: Er ließ sich vorn nicht mehr einschalten. Trotzdem leuchtete mir die NumLock-Lampe an der Tastatur entgegen. Hö? Wie geht das denn? (mehr …)


Spaß mit Tastaturen

Donnerstag, 11. November 2010

Ich hatte gerade noch in einer Textdatei gearbeitet und dabei immer wieder Blöcke kopiert. Mit Ctrl-C. Nach dem Schließen der Textdatei wollte das C nicht mehr reagieren. Beim Durchprobieren stellte sich dann heraus, daß außer dem C auch X und Y nicht mehr wollten. Einfach so. Und das auf der guten IBM-Tastatur, die ich vorgestern noch so gelobt hatte.

Also erstmal die Tastenkappen auf der linken Seite abgezogen und Dreck rausgepinselt und -geklopft. Da kam natürlich was, aber nicht übermäßig viel. Blockierende Krümel hätte ich außerdem beim Schreiben bemerkt. Kappen wieder drauf, danach gingen die Tasten ein paarmal wieder, um dann wiederum zu streiken. Diesmal solidarisierten sich außerdem die linke Ctrl und gelegentlich die 4 (oben) sowie die linke Shift. Na suuper. 🙁 (mehr …)


Verflixtes Kabel

Freitag, 29. Oktober 2010

Letztens hatte ich bei einer Bekannten einen Router installiert. Das Gerät kam vom Telefonprovider, nichts Besonderes, und sollte halt zwischen PC und DSL-Anschluß kommen, um zum einen den PC besser zu schützen und zum anderen den gleichzeitigen Anschluß eines weiteren Rechners ans Netz erlauben. Am Ende funktionierte zwar der Router, aber die Fax-/Drucker-Kombination von HP wollte nicht mehr faxen. Aus Zeitgründen sagten wir dann erstmal: „Da gucken wir demnächst nochmal.”

Demnächst war dann heute. Zudem erklärte mir die Bekannte, sie könne keine „Dateien aus dem Internet” ausdrucken. Aus Word würde es gehen. OK, das war dann erstmal ein anderes Problem: Ich hatte ihr evince als PDF-Reader installiert, der konnte wohl nicht richtig mit dem Drucker kommunizieren. Dann sollte es eben Adobe Reader sein, der konnte. (mehr …)